Moodle 4.4 or later requires at least PHP 8.1 (currently using version 7.3.33-pl9-zoneos). Some servers may have multiple PHP versions installed, are you using the correct executable?